0.2 Prerequisites to use this service